wget下载出现无效证书错误的解决

Linux hhzk 3年前 (2016-08-12) 147次浏览 0个评论

wget 下载时出现 Wget error: ERROR: The certificate of is not trusted.

这种情况是在https下需要证书,系统中没有安装ca证书包导致的。

解决方法:

1 安装 ca-certificates

<code><span class="pln">apt</span><span class="pun">-</span><span class="kwd">get</span><span class="pln"> install ca</span><span class="pun">-</span><span class="pln">certificates</span></code>

2 使用 –no-check-certificate 参数下载

<code><span class="pln">wget \-\-</span><span class="kwd">no</span><span class="pun">-</span><span class="pln">check</span><span class="pun">-</span><span class="pln">certificate https</span><span class="pun">:</span><span class="com">//www.python.org/ftp/python/3.5.1/Python-3.5.1.tgz</span></code>

乐趣公园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:wget下载出现无效证书错误的解决
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址