Debian7编译Shadowsocks-libev出错的解决

Linux hhzk 3年前 (2016-08-12) 99次浏览 0个评论

新做了台vps,编译Shadowsocks-libev出错,提示无法定位dh-systemd和init-system-helpers两个包。
解决方案:
添加这一行到你的/etc/apt/sources.list
deb http://ftp.debian.org/debian wheezy-backports main

原因:debian7默认的源没有dh-systemdinit-system-helpers这两个包,会导致编译失败。
其实shadowsocks的git主页有写,
Note for Debian 7.x users: To build packages on Debian 7 (Wheezy), you need to enable debian-backports to install systemd-compatibility packages like dh-systemd or init-system-helpers. Please follow the instructions on Debian Backports.
没认真看。。。。


乐趣公园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:Debian7编译Shadowsocks-libev出错的解决
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址