解决Proxmox 5 apt-get update 更新时报错

Linux hhzk 1年前 (2018-01-16) 235次浏览 0个评论

proxmox 5下apt-get update时会出现错误:

Err:8 https://enterprise.proxmox.com/debian/pve stretch Release
  401  Unauthorized
Reading package lists... Done
E: The repository 'https://enterprise.proxmox.com/debian/pve stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

是因为需要购买授权才可以使用官方更新。

解决办法:

修改/etc/apt/sources.list.d/pve-enterprise.list注释掉解决,

#deb https://enterprise.proxmox.com/debian/pve stretch pve-enterprise

或者直接删除,哈哈。

rm -f /etc/apt/sources.list.d/pve-enterprise.list

最后,为了更新proxmox,我们可以这样解决:

nano /etc/apt/sources.list

添加:
deb http://download.proxmox.com/debian stretch pve-no-subscription

然后就可以正常apt-get update ,apt-get upgrade,和dist-upgrade ,来自 Proxmox !


乐趣公园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:解决Proxmox 5 apt-get update 更新时报错
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址