将新版shadowsocks编译deb安装

Linux hhzk 2年前 (2017-02-16) 152次浏览 0个评论
apt-get install git

Get the latest source code

To get the latest source code, you should also update the submodules as following:

git clone https://github.com/shadowsocks/shadowsocks-libev.git cd shadowsocks-libev git submodule update –init –recursive

sh -c printf “deb http://httpredir.debian.org/debian jessie-backports main” > /etc/apt/sources.list.d/jessie-backports.list
apt update
apt -t jessie-backports install libmbedtls-dev libsodium-dev

apt-get install –no-install-recommends gettext build-essential autoconf automake libtool \ gawk debhelper dh-systemd init-system-helpers pkg-config asciidoc xmlto apg libpcre3-dev \ libev-dev libudns-dev dh-autoreconf ./autogen.sh && dpkg-buildpackage -b -us -uc -i cd .. dpkg -i shadowsocks-libev*.deb

然后正常修改配置文件,开启服务即可。

nano /etc/shadowsocks-libev/config.json /etc/init.d/shadowsocks-libev start


乐趣公园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:将新版shadowsocks编译deb安装
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址